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LIMITED WARRANTY.  Equipment manufactured by CTI Products, Inc. is warranted to be free from defects in material and workmanship for 

ONE (1) YEAR from the date of shipment to the original purchaser.  Under this warranty, our obligation is limited to repairing or replacing any 

equipment proved to be defective by our inspection within one year of sale to the original purchaser.  This warranty shall not apply to equipment 
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been operated in a manner exceeding its specifications, nor which has been altered, defaced, or damaged by lightning. 

CUSTOMER REMEDIES.  In the event of a defect, malfunction, or failure to conform to specifications established by the seller during the 
period shown, the customer shall call CTI Products, Inc. to obtain a Return Authorization Number and return the product or module, shipping, 

and insurance prepaid.  CTI Products, Inc., will then at its option, either repair or replace the product or module and return it, shipping prepaid, or 

refund the purchase price thereof.  On-site labor at the purchaser's location is not included in this warranty. 

EQUIPMENT NOT MANUFACTURED BY CTI Products, Inc.  Equipment not manufactured by CTI Products, Inc. is excluded from this 

warranty but is subject to the warranty provided by its manufacturer, a copy of which will be supplied to you upon specific written request. 

NO OTHER WARRANTIES.  The foregoing constitutes the sole and exclusive remedy of the buyer and exclusive liability of CTI Products, 
Inc., AND IS IN LIEU OF ANY AND ALL OTHER WARRANTIES EXPRESSED OR IMPLIED OR STATUTORY AS TO 

MERCHANTABILITY, FITNESS FOR PURPOSE SOLD, DESCRIPTION, QUALITY, PRODUCTIVENESS OR ANY OTHER MATTER. 

NO LIABILITY FOR CONSEQUENTIAL DAMAGES.  WITHOUT LIMITING THE FOREGOING, IN NO EVENT SHALL CTI 
PRODUCTS, INC. OR ITS SUPPLIERS BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, 

SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OR FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, 
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PRODUCTS, INC. EQUIPMENT BY PURCHASER OR OTHER THIRD PARTY, WHETHER UNDER THEORY OF CONTRACT, TORT 

(INCLUDING NEGLIGENCE), INDEMNITY, PRODUCT LIABILITY OR OTHERWISE, EVEN IF CTI PRODUCTS, INC. HAS BEEN 

ADVISED OF THE POSSIBILITY OF SUCH DAMAGES OR LOSSES.  IN NO EVENT SHALL CTI PRODUCTS, INC.’S LIABILITY 
EXCEED THE TOTAL AMOUNT PAID BY THE PURCHASER FOR THE EQUIPMENT GIVING RISE TO SUCH LIABILITY. 

 Location: CTI Products, Inc. 
1211 West Sharon Road 

Cincinnati, OH  45240 USA 

 Phone: +1.513.595.5900  

 Fax: +1.513.595.5983 

 Web: www.ctiproducts.com 

 E-mail, Sales: info@ctiproducts.com  

 Technical Support: support@ctiproducts.com 

 
Information contained in this document is subject to change without notice and does not represent a commitment on the part of CTI 

Products, Inc.  No part of this manual may be reproduced or transmitted in any form or by any means, electronic or mechanical, including 

photocopying and recording, for any purpose without the written permission of CTI Products, Inc. 

This manual describes products that include copyrighted CTI Products, Inc. computer programs in semiconductor memory ("Software").  

CTI Products, Inc. reserves all rights for these programs, including the exclusive right to copy or reproduce the copyrighted computer 
programs in any form.  No copyrighted computer program contained in products described in this manual may be copied, reproduced, 

translated, decompiled, disassembled, or reversed engineered in any manner without express written permission of CTI Products, Inc.  The 

purchase of products from CTI Products, Inc. shall not be deemed to grant either directly or by implication, estoppel, or otherwise, any 
license under the copyrights, patents, or patent applications of CTI Products, Inc., except for the normal non-exclusive, royalty fee license 

to use that arises by operation of law in the sale of the product according to the above terms. 

Government Use:  The Software and documentation thereto are deemed to be "commercial computer software" and "commercial computer 
software documentation", respectively, pursuant to DFAR Section 227.7202 and DFAR Section 212.212, as applicable. Any use, 

modification, reproduction, release, performing, displaying, or disclosing of the software or documentation by the U.S. Government shall be 

governed solely by the terms of the above and shall be prohibited except to the extent expressly permitted by the terms of the above.  Any 
technical data provided that is not covered by the above provisions is deemed to be "technical data-commercial items" pursuant to DFAR 

Section 227.7015(a). Any use, modification, reproduction, release, performance, display, or disclosure of such technical data shall be 

governed by the terms of DFAR Section 227.7015(b).  

Copyright (c) 2004-2026 CTI Products, Inc.  All rights reserved. 

CTI, HIB, HIB-IP, HIB-IP 8000, HIB-IP 8002 module, EXB, EXB-IP, MCN™, MCN Server 8000™, and MCNRCD™ are trademarks of 
CTI Products, Inc.   

 

ASTRO®, MOTOROLA, MOTOROLA SOLUTIONS, and the Stylized M Logo are trademarks or registered trademarks of Motorola 
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Other trademarks or registered trademarks are used only for reference. 
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1. INTRODUCTION 

WHAT IS THE BASE RADIO STATUS CONCENTRATOR? 
The Base Radio Status Concentrator (BRSC) is part of the MCN software that emulates a hardware network 

interface. It virtually performs the functions of a network interface and supports connections for up to 240 

GTR 8000 Base Radios. 

 

The BRSC interfaces solely to Motorola GTR 8000 Base Radios. It is not a client to any other application; 

but rather serves statuses back to the MCN Server 8000 software, which acts as a client to the BRSC 

Windows OS service.  

 

WHAT HARDWARE AND SOFTWARE ARE REQUIRED? 
The BRSC is a Hardware Based Licensing option. The software must be installed on a separate PC running 

Windows OS, where it operates as a service. The accompanying diagram shows a setup with a single BR 

connected to the BRSC PC and the MCN Server 8k. 

 

 

  

Figure 1  MCN System using BRSC Network Interface 

When used in this manual, the term MCN Config refers to the versions shipped with the MCN software and 

could be any of the following: 

 Software MCN Configurator  

 MCN Server 8000 MCN Config Server.exe  

 

NOTE: The BRSC is not a physical device, but software that functions as an interface to a GTR 8000 

Base Radio which is a physical device. 

  Part# Description 

S2-61950 MCN BRSC
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2. THE BRSC OVERVIEW 
Support for the BRSC was introduced in software version 10.02.xx. To use this feature, earlier versions of the MCN 

software and systems must be upgraded. This section details the parameters and configurations required in the MCN 

Config program for proper BRSC system integration. Due to variations in system infrastructure and topology, refer 

to your system’s documentation for accurate IP addresses, subnets, gateways, and port numbers. 

 

PARAMETERS FOR CONFIGURING BRSC  

There are configuration parameters i.e., IP addresses and Port Numbers, which must be configured separately, 

for both the MCN Config software and for the BRSC application. 

Network Parameters Worksheet 

Gather the following IP information for the system.  IP information must be obtained for each GTR 8000 

Radio whose statuses are to be monitored (See the network administrator responsible for the IP network to 

which the GTR 8000 Radio are installed): 

GTR 8000 Radio Parameters: 

For each GTR 8000 Radio in the system, gather the following information: 

GTR 8000 ALIAS Name _____________________________ 

GTR 8000 IP Address _______._______._______._______ 

Subnet Mask _______._______._______._______ 

Gateway IP Address  _______._______._______._______ 

 

The MCN Config software must be used to enter all MCN configurations for each system. After 

configuring these parameters, manually upload the information from the MCN Server 8000 to the 

BRSC application. This upload allows the BRSC application to create its local system cache. The 

MCN Server PC that performs the most recent upload will become the designated controlling server 

for that BRSC. 

 

The MCN Config program creates, and maintains the list of: 

• Address parameters for all BRSC NI’s  is in the system (including the MCN Group & Module) 

• Authorized PC List 

 

Each BRSC NI must be configured with its own: 

• Name/ Alias information. 

• Unique IP Address UDP Port:  

The BRSC System information is based on the MCN Configuration system files and must be generated 

from the MCN Config software using the steps in Uploading MCN System Data To the BRSC Server 

Page 8. 

 

Software compatibility:  

 MCN BRSC Version 10.02.23 & up Can connect up to 240 GTR 8000 Base Radios.  

(Requires appropriate licensing.) 
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UPLOADING MCN SYSTEM DATA TO THE BRSC SERVER  
The BRSC is a licensable feature that requires configurations on both it’s client and server side. This 

includes configuring both the MCN Server using MCN Config Server along with configuring the BRSC 

Server with the BRSC HW Setup Application. Also, a USB Dongle and a license key file are required to 

authorize its operation. 

 

To generate the BRSC’s required system data, the MCN Server application alias (MCN SVR 1), must be 

used to perform an upload to the BRSC Service running on a remote PC alias (BRSC 1). After this has been 

completed, the BRSC will be able to create its system files and MCN Server (MCN SVR 1) will become the 

Controlling Server for the (BRSC 1). 

 

MCN Server 8000 Upload to BRSC Server 

   Use the following steps to complete the data upload for BRSC 1: 

 

1. Verify the correct IP Address of the GTR 8000 Base Radio.  

2. Verify that the GTR 8000 Base Radio is Powered on and connected on the proper Subnet.  

3. Start the MCN Server and Load the system that was configured for the BRSC Network Interface. 

 

  

  

 

 

 
  

 

 

 

 

 

 

 

 

 

 

 

 

4. The MCN Server PC (MCN SVR 1) would use the MCN Config software to prepare the system 

data. 

5. In the previous diagram note that the Data was uploaded at 12:35PM from MCN SVR 1 to the 

BRSC 1 Service running on the remote BRSC PC 1.( This is the most recent upload) 

6. The BRSC 1 would receive the uploaded data and use it to create local system data files. 

7. BRSC 1 will create and maintain a local cache based on the uploaded data. 

8. After the upload, MCN SVR 1 becomes the controlling server for the BRSC1 because it was the 

most recent initiator of the data that was uploaded. 

  

MCN 

SVR 2 

BRSC 1 

SVC 

PC 1 

MCN 

SVR 1 

Local 

Cache 

CTRL SVR = MCN SVR 1 

MCN 1 Uploads at   

12: 35 PM 
MCN 2 Uploads at   

12:55 PM 
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Switching The Controlling Server 
 If at any later time the MCN SVR 2 needed to be assigned as the controlling server for  BRSC 1 

then this would be the process: 

1. The MCN Server PC MCN SVR 2 would use it’s MCN Config software to prepare the system 

data. 

2. The Data is uploaded at 12:55 PM from MCN SVR 2 to the BRSC 1 Service running on the 

remote BRSC PC 1. (This will then be the most recent upload.) 

3. The BRSC 1  receives the uploaded data and uses it to create new system data files. 

4. The BRSC 1 creates and maintains a local cache based on the uploaded data. 

5. After completing the upload, MCN SVR 2 becomes the new controlling server for BRSC 1 

because it was the most recent server to upload data. 
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3. BRSC SERVER INSTALLATION 

ABOUT THE BRSC SERVER 
BRSC’s core software installs and runs as an independent service that exclusively connects to GTR 8000 Base 

Radios. It operates on a dedicated Windows PC and does not rely on other applications. Its main functions 

include gathering transmitter statuses from GTR 8000 Base Radios and sending this data to MCN Server 8000, 

which acts as a client to the BRSC Service. 

Key Attributes of the BRSC Server: 
• Network Interface: Acts as a bridge within the MSI network. 

• Exclusive Connection: Interfaces only with GTR 8000 Base Radios. 

• Status Display: Locally shows transmitter statuses from connected radios. 

• Client Communication: Forwards transmitter statuses to designated client remote applications. 

• Standalone Operation: Does not interact with or rely on other applications. 

Requirements: 
1. License Authorization: 

 USB Dongle required. 

 License key file needed. 

2. Configuration Setup: 

 BRSC HW Setup: Install and configure both the BRSC Server and an  

exclusive BRSC Client. 

 MCN Config Server: Configure the MCN Server as a client for the BRSC. 

 

INSTALLING BRSC SERVER ON A DEDICATED PC  

1. Begin the installation. 
Run Base Radio Status Concentrator install x64 V10.xx.xx.exe on a separate host PC to install the 

BRSC software. And follow the prompts to complete the installation. 

 

Click ‘Next’ to Load the Installer for the BRSC software: 
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2. Accept License Agreement 
  Select the ‘I accept …’ and, then Click ‘Next;’ If you agree to the Software License Agreement: 

 

 

 

 

3. Install The Software.   
Click ‘Install’ to begin the Software Installation: 
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4. Install USB Drivers. 
The Advanced Installer will proceed to install the following components: 

BRSC software : 

• MCN License Server. 

• Safenet USB Device Drivers 

 

 

It is imperative that the BRSC not be installed to cohab on the same PC as the MCN Server 

application. However, if there is an existing MCN product which uses the MCN License 

Server, either of the following errors could be presented. 

     

Click ‘Ignore’ to continue installing all other software components. 

 

 

The USB Dongle Drivers will be needed to support the Hardware Key. 

 

Click ‘Next’ 
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   The following screen is presented after the USB driver has been installed. 

 

Click ‘Finish’ to complete the installation. 

 

5. Install Software License  
  You will need to provide the License Key File on the next screen. 

 

 

Click the ‘Key File’ button, navigate to the location where the License Key File is saved,  

select it, and then click ‘Next’ to proceed. 

 

In the following window(If the PC has Multiple NICs) the correct Network Interface must be 

verified or selected.  
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6. Add Authorized PCs  
In the following window, the IP address for each PC that will have the rights to connect and share 

data with the BRSC must be added. 

 

The next window configures the Destination IP address for the RFM PC or ATIA repeater based 

on the specific system hardware and infrastructure . 

 

Enter the appropriate IP address and Port number of the device that the BRSC will be sending data 

to. 
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7. Verify License & Configuration Data. 

Verify that all the configuration parameters are correct. 

 

Check that all the information entered previously is compatible for your specific IP network and its 

devices. Then Click “OK.” 

 

In the following windows, Click ‘Finish’  to complete the installation. 
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4. BRSC SERVICE/APPLICATION 
From the desktop of the BRSC PC, Open the CTI Products Folder and ‘Click’ the BRSC Desktop icon. 

 

 

The screenshot above shows the BRSC Main Screen before any system has been loaded. The service will 

only become operational after a system has been generated. 

 

BRSC Operation  

Acquiring The BRSC System Files 

Data from the MCN Server 8000 must be uploaded to the BRSC processing service to generate the 

necessary system files for its operation. The BRSC will not operate without this critical system 

parameter information. The system configuration provided by this data is essential for the BRSC to 

establish a connection with the GTR 8000 Base Radios and to relay Base Radio statuses back to the 

MCN Server.  

 

After the MCN data is uploaded, the BRSC service may need to be reloaded or restarted to generate its 

system file from the new data that it receive from the MCN Server. 

BRSC Operating Modes 

The BRSC has two possible modes in which it operates: 

1. Service Mode 

2. Application Mode 

Service Mode (BRSC Viewer) 

• Activation: In service mode, the operation starts automatically and runs in the 

background without any user interface. 

• Primary Purpose: This mode is designed for continuous, unattended operation. 

• Application: The BRSC Viewer is used to provide a display of the operational status for 

the service. 
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Application Mode (BRSC Desktop)  

• Activation: BRSC Desktop mode needs to be started manually. 

• Primary Purpose: It’s designed for verifying and troubleshooting the BRSC Process. 

• Application: The BRSC DeskTop application is used to operate in this mode. 

 

 

Note It is important to remember that both services can not be run at the same time, as they 

perform the exact same function 

 

BRSC DeskTop 

When you run the BRSC Desktop you will be operating in the Application mode, and the following 

window will pop up. 

 

 

 

If the BRSC service fails to connect to the BR while starting up it may be necessary to reload the system 

by clicking on the “File”        “Reload System” as seen in the next screen shot. 

 

 

The Reload System action will also check and show the GTR connection status. 
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OPTIONS Menu 
The “Options” menu allows you to configure the BRSC’s display via the following : 

• Font settings,  

• RFM client and  

• BRSC’s Network settings. 

 

The Font menu 
The "Font" menu provides settings where you can adjust the appearance of text in the screen 

window. The options include the following: 

o Font Selection 

o Font Point Size 

 

 

The RFM menu 
This menu allows RFM client to be enabled or disabled, and its destination address configured as 

shown in the following “RFM Target” window menu. 
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The Network Settings menu 
The "Network Settings" menu is where you configure and manage network-related settings of the 

BRSC application. The configurable options include the following: 

 IP Address to MCN Server  

 Control Port 

 Enable Multicast 

 Multicast IP Address to MCN Server 

 Multicast Port 

 

 

IP Address To MCN Server 
This is the IP address for the NIC of the PC on which the BRSC is installed and running. 

 

Control Port 
This is the dedicated port used by the BRSC application to send and receive control 

commands between the server and client. 

 

Enable Multicast 
This activates the multicast method used to efficiently transmit data from the server to 

multiple recipients across the network. 

 

Multicast IP Address to MCN Server 
The addresses used here must fall within the specified ranges designated for multi-cast 

traffic. 

 

Note: Not all networks or devices fully support multicast traffic. Assistance from an IT 

network specialist may be required to verify compatibility or configure network 

devices correctly. 

Multicast Port 
Multicast ports are the specific port numbers used in conjunction with multicast IP addresses 

to send and receive multicast traffic over the IP network. 

 

  



 CTI Products, Inc.  BRSC Desktop Application 

4 Operation Modes 20 

VIEW Menu 

The View menu provides options that control how information is displayed on the screen. 

  The View Menu options include the following:  

o Status Bar 

o Topmost Window 

o GTR Status 

o Tab Selector 

o Layout 

 

 

Status Bar 
The status bar is a user interface element that provides real-time information and feedback about 

the current state of the application. 

 

The “Topmost Window” 
The "Topmost Window" is a feature that allows a window to stay on top of all other windows 

regardless of which application is currently active. 

Benefits: 
 Multitasking: Keeps important windows visible while you work in other applications. 

 Monitoring:   Ensures that a monitoring tool or dashboard remains visible with real-

time updates.  

BRSC Client Status 
The BRSC Client Status allows for the monitoring and tracking of those clients that are authorized 

and successfully connected to the BRSC server as seen in the following window.  
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GTR Status 
This will display the connection status of the GTR Base Radios. 

 

Tab Selector 
This is a user interface element used to efficiently navigate between different sections or 
panels within the same window. 

 

Layout 
The goal of the layout function is to allow users to configure the screen in a way that is 
both aesthetically pleasing and functional, making it easier to interpret the displayed 
information. 

 

Display Element Properties 
More information can be obtained about GTR Base Radio by performing a Shift - Left Click 

over the particular screen element and bringing up the Display Element Window. 

 

 

Display Element: 

– Name   BR / Receiver name from MCN Configuration files. 

– Description Field from MCN Configuration files. 

– Tag1, Tag2  Fields from MCN Configuration files. 

– Display Table Field from MCN Configuration files. 

Device: 

- Device Name Device name for this GTR from MCN Configuration files. 
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- GTR IP Addr IP Address of the GTR on the network from MCN Configuration 
files. 

- NI Name   Network Interface name for the BRSC from MCN Configuration 
files. 

- Channel   Channel name associated with this GTR from MCN Configuration 
files. 

- Tx     GTR index\subsite number in the BRSC from MCN Configuration 
files. 

- Display Value Raw status value that is processed through the Display Table 

- Port     UDP port assigned to that GTR from the Dynamic Port Range on 
the BRSC PC. 

 
 

 

 

 

HELP Menu 

The Help Menu provides access to the following: 

• Help Topics 

• Operating System Info  

• About BRSC 

• Software Key 

 

 

Help Topics 
This option provides access to PDF documentation that assist users in understanding and 
effectively using the BRSC software application, 

 

Operating System Info 
This option provides a summary of information about the computer operating system on 
which the BRSC Application is running. 

 

About BRSC 
This option provides details about the BRSC software such as “Version,” “Copyright” and 
“Licensing” information. 
 

Software Key 
This provides the option to Verify, or Change the software key, which is a unique code 
used to activate or validate software. 
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BRSC Viewer 

The BRSC Viewer is the application used to provide a display with the operational status of the BRSC 

service. 

 

 The following are Screen shot of the BRSC Viewers interface. 

 

Menu       File 

 
The File menu provides options the option to Start, Stop, or Exit. 

 

 

Menu       Options 

 
The "Font" menu provides settings where you can adjust the appearance of text in the screen 

window.  

 

The font options include the following: 

o Font Selection 

o Font Point Size 
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Menu       View 

 

The View menu provides options that control how information is displayed on the screen. 

The View Menu options include the following:  

o Tool Bar 

o Status 

o Client 

o Layout 

o Refresh 

 

 

Menu       View        Tool Bar 

The Tool Bar menu provides access to the file open function. 

 

 

Menu       View        Status 

The status displays the current status of the application and its operation. 

 

 

Menu       View        Clients 

 

 

The Client menu displays the list of the authorized clients. 

 

  



 CTI Products, Inc.  BRSC Desktop Viewer 

4 Operation Modes 25 

Menu       View       Layout Mode 

 

 

The Layout menu provides options for arranging and organizing the displayed screen. 

 

Menu       View       Refresh 

The Refresh function updates or reloads information displayed on the screen. 

 

Menu        Help        About BRSC Viewer 

 

 
This option provides details about the BRSC Viewer software such as “Version,” 

“Copyright” and “Part number” information. 
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5. SETUP FOR BRSC CLIENTS  

CLIENT TYPES 
Both the RF Monitor software (RFM)and the MCN Server 8000 software can connect as clients to the BRSC 

server, where they can receive the base radio status updates from the BRSC server. The following discusses 

each client’s option: 

RF Monitor as a Client 
The RFM client connects to the BRSC server to retrieve and display the status information of BR 

transmitters  remotely. It allows users to view on a separate dedicated PC, the BR transmitter status updates 

that are gathered from the BRSC server.  It requires the BRSC HW Setup for installation and configuration. 

MCN Server 8000 as a Client 
The MCN Server 8000 is a standalone server for comparator control but can also function as a client to the 

BRSC server, where it receives BR transmitter status information, that it then displays as updates on its 

"Display Window Screen." 

The BRSC Network Interface can only be added and configured for the MCN Server 8000 software, using 

the MCNConfig Server Version 10.xx or later. 

Client Setup: 

After installation, you must enter the appropriate IP parameters in both the MCN Server and RFM 

Applications, for them to connect them as clients to the BRSC Service: 

Configuration for RFM 
The BRSC can be configured in the BRSC APP to send BR data directly to the RFM application. 

Under Options RFM  you will need to check the  “Enable RFM” box and enter the 

appropriate IP Address and Port Number for the RFM PC that the data will be forwarded to. 

 

Configuration for MCN Server 8000 

To configure the MCN Server 8000 as a client for the BRSC, you need to complete configurations 

in two distinct locations: 

In The MCN Config 
Before the MCN Server can communicate with the BRSC Service, it needs to be configured 

with a GTR Network Interface. This setup allows the MCN Server to properly connect to the 

BRSC Service. Check the MCN Server 8000 manual under “The BRSC Clients” section for 

step-by-step instructions on configuring BRSC in the MCN config Server Application.  
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In The BRSC APP 
Additional configuration must be made in the BRSC APP to enable Multicast BR: 

– Open the BRSC Application: 

Launch the BRSC app on your device or system. 

– Navigate to Options: 

Look for the “Options” menu. This is located in the above main menu or settings area 

of the app. 

– Go to Network Settings: 

Within the “Options” menu, find and select “Network Settings.”  

– Enable Multicast: 

In the Network Settings, locate the “Enable Multicast” checkbox. Ensure this box is 

checked to activate multicast functionality. 

– Enter Multicast IP Address: 

In the field for the Multicast IP Address. Enter the appropriate multicast IP address for 

your RFM Multicast group. This address is used to route multicast data to all devices 

that are subscribed to the Multicast group. 

– Enter Port Number: 

In the field for the Port Number. Enter the port number that corresponds to the 

assigned multicast group.  

– Save Changes: 

After entering the IP address and port number, make sure and Click OK to save or 

apply the changes. The process will require allowing the MCN Option settings 

to make changes. 

– Verify Configuration: 

The New settings will not take effect until the program has been restarted. Click 

“NOW” when prompted to “End” the BRSC. Then restart the BRSC and check that 

the settings have been applied correctly.  
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6. COMMON  QUESTIONS 
Here are some common questions about the Base Radio Status Concentrator (BRSC). 

These questions can help you better understand the BRSC's capabilities, setup, and operation: 

 

1. Functionality: 

o What is the primary purpose of the BRSC in the MCN system?  

Answer: See Page 6 “ What is The Base Radio Status Concentrator?” 

o How does the BRSC interface with GTR 8000 Base Radios?  

Answer: See Page 6 “What is The Base Radio Status Concentrator?” 

 

2. Installation: 

o What are the steps to install the BRSC software on a dedicated PC?  

Answer: See Pg 10 “ Begin the installation.” 

o What hardware and software requirements are needed for BRSC installation?  

Answer: See Pg 6  “What Hardware and Software are required?” 

 

3. Configuration: 

o How do you configure the BRSC to connect with the MCN Server 8000?  

Answer:  See Pg 26  “In The MCN Config” 

o What network parameters need to be set for the BRSC?  

Answer:  See Pg 7 “ Network Parameters Worksheet” 

 

4. Licensing: 

o What licensing components are required to operate the BRSC? 

Answer:  See Pg 22 “Software Key” 

o How do you verify or update the BRSC license key?  

Answer:  See Pg 22 “Software Key” 

 

5. Operation: 

o What are the differences between Service Mode and Application Mode in BRSC?  

Answer: See Pg 16  “BRSC Operating Modes” 

o How can the BRSC system files be acquired and updated?   

Answer: See Pg 16  “Acquiring The BRSC System Files” 

 

6. Troubleshooting: 

o What are common errors encountered during BRSC operation, and how can they be resolved? 

Answer:  See Pg 32  “COMMON BRSC ERRORS 

o  

o BRSC NI Open Rejected Error 

 
o ” 
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o How can you verify the connection between BRSC and its clients (MCN Server 8000 or RFM)? 

Answer: See Pg 30 “ Client Verification:” 
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7. Security: 

o What security measures should be implemented when using the BRSC? 

Answer: See Pg 38 “Appendix A.   Security and Information Assurance Recommendations” 

o How can access to the BRSC system be restricted to authorized PCs?  

Answer: See Pg 14, “Add Authorized PCs ” 

 

8. Compatibility: 

o What software versions are compatible with the BRSC?  

Answer: See Pg 7, “2. The BRSC Overview ” 

o Can the BRSC be used with other base radios besides the GTR 8000? 

Answer:  NO,  See Pg 6  “ What is The Base Radio Status Concentrator?” 

 

9. Client Setup: 

o How do you configure the RFM application as a client for the BRSC?  

Answer: See Pg 8 “Uploading MCN System Data To the BRSC Server” 

o What steps are required to set up the MCN Server 8000 as a client for the BRSC?  

Answer: See Pg 26, “Configuration for MCN Server 8000 ” 

 

10. Performance: 

o How does the BRSC handle data from up to 240 GTR 8000 Base Radios?  

Answer: See Pg 8, “Uploading MCN System Data To the BRSC Server  ” 

o What are the benefits of using multicast functionality in the BRSC? 

Answer: See Pg 19, “Enable Multicast  ” 
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7. TROUBLESHOOTING & TESTING  
 

PINGING THE BASE RADIO 

The “Ping” function can be run from the PC as a diagnostic tool to determine if a particular IP address can be 

“reached” when a selected PC is used as the packet source. Also, it will confirm whether or not the local 

network is configured to pass (ICMP) Ping messages and responses.  The Base Radio should respond to any 

ICMP Ping packets that originate from its Local IP network.   

Note: Some networks are configured to block the ICMP Ping messages and/or responses between certain 

network segments of subnets.  The Ping function will not work if the ICMP Ping messages or responses are 

blocked between the networks. 

 

If ICMP Pings are blocked from your source network, you may be able to log into a remote router or 

managed IP switch at the Destination Local Network of the Base Radios and ping the unit from that router 

or IP switch.  

 

VIEWING PARAMETERS OF THE BRSC 

The Hardware parameters of the Base Radio can be viewed by opening the existing MCN BRSC system files 

with MCN config Server program.  

If there is not an existing MCN system, then this information must be gathered by: 

• reading the Base Station Radio with a compatible version of the Motorola CSS software  

• or by making a request to an authorized Systems Technician or Engineer. 

 

CLIENT VERIFICATION: 
It is a good idea to verify the multicast functionality by running the MCN Server and RFM Application clients 

to see that they connect to BRSC: 

– Evaluate RFM’s Connection:  

Verify the connection between the BRSC’s RFM client and the BRSC Service to ensure they 

connect. 

– Evaluate MCN Server 8000’s Connection:  

Verify the connection between the BRSC’s MCN Server 8000 client and the BRSC Service to 

ensure they connect. 

– Check Status:  

Verify that both BRSC’s MCN and RFM Clients are receiving and processing data correctly. 
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TROUBLESHOOTING GUIDE 
This troubleshooting guide provides step-by-step solutions for common issues encountered during the 

installation, configuration, and operation of the Base Radio Status Concentrator (BRSC). Identify the Issue you 

are experiencing and follow the solution steps to resolve the problem. 

 

Common  MCN Errors 

Class Not Registered 

Symptom: The ‘Class not registered’ warning error, could pop up while building a system in the 

MCNConfig Server, and is an indication of a configuration error.  

 

This message offers no clarity by itself but, will typically be accompanied by additional pop ups 

similar to the next Warning  window. 

 

The following Warning screen might pop up in association with the previous one and together 

provides more insight about the kind of configuration error that exist. 

 

The above warning error indicates that one of the Display Tables that is required within the currently 

loaded system is not a part of the available set of Display tables. 

➢ Solution 

To correct this issue, do the following: 

- Open the MCN Config Server application. 

- Click the View →Display Tables. 

- While on the Display window click Edit → Manage Display tables 

and the following  window will open. 

 

- Select the missing table from the list of default tables on the Left pane and Click Add. 
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COMMON BRSC ERRORS 
 
1. BRSC NI Open Rejected Error 

 

Symptom: The BRSC Open Rejected error will occur if the Server PC that is trying to connect to the 

service is not in the Authorized IP Addresses list. 

 

 

 

➢ Solution 

- From the PC running the BRSC Service, ‘Open’ CTI Products Folder and ‘Run’ 

BrscSetup.exe 

- Click ‘Next’ to navigate to  the ‘Network Interface Selection’ window,  

 

- Click ‘Add IP’ to add the address for the New Server that you wish to be allowed 

connection. 
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- Click ‘Next’ until you see the ‘Verification’ Window.  

 

- Click ‘OK’ 

 

2. Database Error (DTB Error) 

Symptom This configuration error will occur if there are problems Linking the Devices in the 

Display Table Or stated another if you try to add BRSC without the proper Display Table being 

loaded for the system. 

 

 

➢ Solution 

To correct this issue, do the following: 

- Open the MCN Config Server application. 

- Click the View →Display Tables. 

- While on the Display window click Edit → Manage Display tables. 

the following window will open. 

 

- Select the missing table from the list of default tables on the Left pane and Click 

Add. 
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3. Installation Problems 

Issue: USB Driver Installation Error 

Symptom: USB driver fails to install, or the USB dongle is not recognized. 

➢ Solution:  

- Ensure the USB dongle is properly connected to the PC. 

- Verify that the USB port is functional by testing with another device. 

- Reinstall the USB driver using the BRSC installation package. 

- Restart the PC after installation to ensure the driver is loaded correctly. 

 

Issue: License Key File Not Found 

Symptoms: The installation process cannot proceed due to a missing license key file. 

➢ Solution:  

- Verify the location of the license key file. 

- Ensure the file is accessible and not corrupted. 

- If the file is missing, contact CTI Products, Inc. technical support at 

support@ctiproducts.com to request a replacement. 

 

4. Configuration Issues 

Issue: BRSC NI Open Rejected Error 

Symptom: The BRSC service rejects the connection request from the server PC. 

➢ Solution:  

- Open the CTI Products folder on the PC running the BRSC service. 

- Run BrscSetup.exe. 

- Navigate to the "Network Interface Selection" window. 

- Click "Add IP" and enter the IP address of the server PC that needs access. 

- Click "Next" until the "Verification" window appears. 

- Click "OK" to save the changes. 

 

Issue: Database Error (DTB Error) 

Symptom: The BRSC displays "DTB Error" in the status column, indicating issues with the display 

table configuration. 

➢ Solution:  

- Open the MCN Config Server application. 

- Navigate to View → Display Tables. 

- Click Edit → Manage Display Tables. 

- In the "Manage Display Table Templates" window, select the missing table from the list of 

default tables in the left pane. 

- Click "Add" to include the missing table in the system. 

- Save the changes and restart the BRSC service. 
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Issue: Missing Display Tables 

Symptom: A warning message appears indicating missing display tables. 

➢ Solution:  

- Open the MCN Config Server application. 

- Navigate to View → Display Tables. 

- Click Edit → Manage Display Tables. 

- Select the missing table from the list of default tables in the left pane. 

- Click "Add" to include the missing table in the system. 

- Save the changes and restart the BRSC service. 

 

5. Connectivity Issues 

Issue: Unable to Ping Base Radio 

Symptoms: The Base Radio does not respond to ICMP ping requests. 

➢ Solution:  

- Verify the IP address of the Base Radio. 

- Ensure the Base Radio is powered on and connected to the correct subnet. 

- Check the network configuration to ensure ICMP ping messages are not blocked. 

- If ICMP ping is blocked, log into a remote router or managed IP switch at the destination 

network and attempt to ping the Base Radio from there. 

 

Issue: BRSC Service Fails to Connect to Base Radio 

Symptom: The BRSC service cannot establish a connection with the Base Radio. 

➢ Solution:  

- Verify the Base Radio’s IP address, subnet mask, and gateway settings. 

- Ensure the Base Radio is powered on and connected to the network. 

- Restart the BRSC service and reload the system files by selecting File → Reload System 

in the BRSC Desktop application. 

 

Issue: Clients Cannot Connect to BRSC 

Symptom: The MCN Server 8000 or RFM application fails to connect to the BRSC service. 

➢ Solution:  

- Verify the IP address and port number settings in the BRSC application under Options → 

Network Settings. 

- Ensure the client PC’s IP address is added to the authorized list in the BRSC setup 

(BrscSetup.exe). 

- Check the multicast settings in the BRSC application and ensure they match the client 

configuration. 

- Restart the BRSC service and the client applications. 
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6. Operational Issues 

Issue: BRSC Service Not Generating System Files 

Symptom: The BRSC service fails to generate system files after data upload. 

➢ Solution:  

- Verify that the MCN Server 8000 has successfully uploaded system data to the BRSC 

service. 

- Restart the BRSC service to reload the system files. 

- Check the BRSC Desktop application for any error messages or warnings. 

 

Issue: BRSC Viewer Displays Incorrect Data 

Symptom: The BRSC Viewer shows incorrect or incomplete data. 

➢ Solution:  

- Verify the connection between the BRSC service and the Base Radios. 

- Check the network parameters and ensure they are correctly configured. 

- Reload the system files in the BRSC Desktop application by selecting File → Reload 

System. 

 

7. Performance Issues 

Issue: Slow Data Transmission 

Symptom: Data from Base Radios is delayed or not transmitted efficiently. 

➢ Solution:  

- Check the network bandwidth and ensure it is sufficient for the number of connected 

Base Radios. 

- Verify that multicast functionality is enabled and properly configured in the BRSC 

application. 

- Consult your network administrator to ensure the network infrastructure supports 

multicast traffic. 

 

8. Security Issues 

Issue: Unauthorized Access to BRSC 

Symptom: Unauthorized PCs are able to connect to the BRSC service. 

➢ Solution:  

- Open the BRSC setup (BrscSetup.exe) and navigate to the "Authorized PCs" section. 

- Remove any unauthorized IP addresses from the list. 

- Implement strong passwords and restrict physical access to the BRSC PC. 
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Contact Technical Support 

If the issue persists after following the troubleshooting steps, contact CTI Products, Inc. Technical support for 

assistance: 

• Phone: +1.513.595.5900  

• Email: support@ctiproducts.com  

• Website: [www.ctiproduct  
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APPENDIX 

APPENDIX A.   SECURITY AND INFORMATION ASSURANCE RECOMMENDATIONS 

Review these recommendations before installation and follow them during installation and operation: 

1. Software Installation Locations 

Install the BRSC software on a Separate PC, and  in the default program directory recommended by 

Installer software. 

2. Configure the BRSC software . 

3. Do not save user files or system configuration files in the program directory.  

4. Save system configuration files to a directory that requires Administrator rights so that users cannot delete 

or edit the configuration files.  

5. Always run the configuration software with the lowest permission set possible. 

Note:  The MCN Config Server software must be run with Administrator rights. 

6. When configuring a system, do not enter Sensitive or Confidential information into the system 

configuration files. 

7. Follow the applicable Backup & Recovery procedures for your system, PCs, and operating systems as 

defined by your organization, the hardware and software vendors, and commercially acceptable practices. 

8. Limit access to PCs, IP networks, and MCN networks, both physically and through appropriate restrictions 

on routers and switches 

9. Use strong passwords where applicable. 

10. Follow your radio system provider's and your organization's recommendations on security and Information 

Assurance. 

11. Use the appropriate Windows Hardening Kits for PCs in your system. 

12. Use anti-virus and anti-malware packages on PCs in your system. 

13. Install appropriate security patches for installed software and operating system on PCs in your system. 
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